Requirements for adding an integration to Works with GitHub

Note: We no longer support GitHub Services as of October 1, 2018, and GitHub Services will stop working on January 31, 2019. Please see the blog post for details. You can use the Replacing GitHub Services guide to help you update your services to webhooks.

Integrations on Works with GitHub must meet several requirements before they can be added.

  • The owner or author of the integration must add the integration to Works with GitHub.
  • Integrations must relate to the GitHub service, data, or users.
  • Integrations must comply with GitHub's Terms of Service, Privacy Policy, and Community Guidelines.
  • Integrations cannot actively persuade users away from GitHub.